观察|以太坊伦敦升级已后矿工应该注意什么?

释放双眼,带上耳机,听听看~!
 以太坊

客户端版本

为了与伦敦升级兼容,节点运营商需要升级他们正在运行的客户端版本。下表显示了支持以太坊主网伦敦升级的所有客户端的版本号。这些版本不同于先前发布的支持测试网络伦敦升级的版本。以前的几个版本不支持以太坊主网络的伦敦升级。

 以太坊

支持以太坊主网升级的客户端版本号

小心:

1.Besu客户端版本于2021年8月4日更新,主要用于修复与伦敦升级无关并影响交易池的错误。

2.Go以太坊、nETHermind和erigon客户端版本于2021年7月23日更新,主要解决ropsten测试网络的一致性问题。

3.在伦敦升级后,OpenEM客户端将被放弃,OE团队正在与erigon合作,为用户提供平稳过渡。

伦敦升级EIP

伦敦升级包括以下EIP:

  • ​EIP-1559:ETH 1.0链交易手续费市场变化
  • EIP-3198:BASEFEE操作码
  • EIP-3529:减少退款
  • EIP-3541:拒绝以0xEF字节开头的新合约
  • EIP-3554:难度炸弹延迟至2021年12月1日

需要注意的是,尽管EIP-1559向后兼容当前事务格式,但它已经更改了块头,添加了新的事务类和新的JSON RPC端点,并更改了多个场景(挖矿、交易池等)中的操作。强烈建议项目方熟悉伦敦EIP升级的内容。

以太坊用户或ETH持有人需要做什么?

如果您正在使用exchange(如coinbase、Kraken或binance)、web钱包(如metamask、mycrypto或myETHerwallet)、移动钱包(如coinbase钱包、trust钱包)或硬件钱包(如ledger、trezor),则无需执行任何操作,除非exchange或钱包服务通知您采取其他步骤。

非挖矿节点运营商需要做什么?

如果运行自己的以太坊节点,则需要升级节点。根据上面列出的客户端版本号下载以太坊客户端的最新版本。

矿工们需要做什么?

首先,根据上面列出的客户端版本号下载以太坊客户端的最新版本。然后,您需要手动将气体限制设置为现在的两倍。例如,在伦敦升级之前,您将区块容量设置为15000000 gas,因此现在需要将区块容量设置为30000000 gas。这是因为一旦伦敦升级被激活,区块容量将翻倍,EIP-1559将使区块大小保持在区块容量的50%左右。这可以在通过json rpc端点与主网络的伦敦升级兼容的所有客户端上完成,而无需重新启动节点。

下表显示了每个客户端需要调用的API接口,以调整气体限值。

 以太坊

注意:nETHermind、erigon和ETHereumjs不支持在以太坊主网上进行挖矿。

网络升级是如何发生的?

在社区就哪些EIP应包含在升级中达成共识后,协议的更改将写入各个以太坊客户端,如get、erigon、besu和nETHermind。对这些协议的更改将在特定块中激活。任何未升级到新版本的节点都将在旧链上丢弃,旧规则仍将在旧链上使用。

矿工或节点运营商不升级会怎样?

网络升级是为了更改底层以太坊协议,并创建新规则以改进系统。区块链的去中心化使得网络升级更加困难。以太坊网络升级需要与以太坊社区和每个以太坊客户端的开发者进行沟通和合作,以确保升级的顺利进行。

如果矿工或节点运营商的以太坊客户端未升级到上述最新版本,则在伦敦升级后,您的客户端将继续在硬分叉之前同步链。您将被困在不兼容的链条中,无法发送以太网或在伦敦升级的以太坊网络上运行。

给TA买糖
共{{data.count}}人
人已赞赏
头条资讯

深度|2021年数字资产市场结构与投资者保护法分析

2021-8-8 9:00:54

头条资讯

美国新的加密货币税收计划可能会扼杀新的区块链技术

2021-8-8 9:08:39

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索